New to me 04 Hatch, 2nd Mazda3

Discussion in 'The Intros' started by fireguy, Sep 5, 2012.

  1. fireguy

    fireguy New Member

    I've been driving ZX2's for the better part of the last 9 years. Got an 07 Mazda3 in 2010 that the girlfriend drove for the last two years and I got to drive it for the last few months:

    [​IMG]

    But I got tired of feeling like a robot driving it and picked up a 5 speed hatch:

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    And then I found this terrifying creature lurking in my spare tire well:

    [​IMG]

    It's not as nice [clean] as the 07, but pretty damn clean for an 04 with 133k miles (single owner too) on it. Has leather, nav, moonroof, foglights.. but no Aux-In? WTF?

    I need to replace the rear-view mirror and grill which are broken. I'd like to do something with the awesome cracked dash right up by the windshield as well. The AC seems to work intermittently (fan seems to blow correctly at proper speeds).. I'd love to figure out how to wire another DVD player up to the nav and route the audio to an Aux-In on the Tape/MD. The radio and all my burned CDs from high school/junior high are not really cutting it anymore..

    I don't really have many plans for it as I just don't have the time. I want to tint the windows legally (50% in this wonderful state) and get some kind of roof rack for a couple bikes. I really just want to keep the car clean and drive it forever or until I can afford a newer one.
     
  2. escort1991

    escort1991 New Member

    Welcome to MNMAZDA! What part of Central MN are you from?

    Car looks pretty good. I drive an 04 hatch, 5spd as well, but in silver. Wish I would have picked one up with the same options as yours has. But, couldn't afford it at the time.

    Anyhow, welcome.
     
  3. mndsm

    mndsm I'M OFFENDED!

    Aux in wasn't standard until the 07 refresh. my 05 SP23 didn't have one either.... but my speed3 does.
     
  4. matt8478

    matt8478 New Member

    Welcome
     
  5. fireguy

    fireguy New Member

    Thanks all,

    I'm in the Cloud area.
     
  6. spek1098

    spek1098 Guest

  7. 1Kris06

    1Kris06 MAD LIGHTS YO

  8. fireguy

    fireguy New Member

    Yeah, I stumbled upon the auxmod as well. I can't decide whether it's worth $60 on the auxmod or just upgrade the head unit altogether.
     
  9. fireguy

    fireguy New Member

    Sorry for the double post, I can't edit my posts?

    Anyone else on here in the St. Cloud area - Sartell, Waite Park, Sauk Rapids?
     
  10. spek1098

    spek1098 Guest

    Think you need a certain amount of posts before you can edit. Yea, that price is absurdly high, think it was 30 or 35 when I bought it.
     
  11. escort1991

    escort1991 New Member

    I know there is an Apple hookup as well. Not sure how much it is exactly as it was already installed in my car when I got it. But I do like this AuxIn cable as well.

    I use to go to the Paynesville area quite a bit when i was a kid. My grandparents had a farm up there.
     
  12. fireguy

    fireguy New Member

    No need for the Apple one as my iPod got jacked out of my last ZX2. I'm actually from Willmar and still frequently commute there-if you didn't know they built a bypass on 23 around Paynesville now which is super nice. You have a history of Escorts too? Seems like quite a few people move from them to a Mazda of some sort.
     
  13. dmention7

    dmention7 Hater

    I went from a 95 EGT to a Mazda3, and now I've got a 95 escort wagon again. So, from poopy ford car with good mazda engine, to good mazda car with okay mazda engine, to poopy ford car with poopy ford engine. I am not a clever man.
     
  14. mndsm

    mndsm I'M OFFENDED!

    LOL strangely enough, the car I bought when I wrecked my DSM (to commute in since it was cheaper than a rental car) was a Ford Escort Wagon. That was an 89 though, not as fancy as some of these newer escorts. Got the DSM back, blew it up, crushed it and got a Mazda 3. Then traded that in for the ms3 I have now.
     
  15. escort1991

    escort1991 New Member

    Yep, first car was a 91 escort 1.8L, 5spd 5 door hatch with 4 10s and a 1000 watt amp. Then, went to a 95 Contour with a 2.0L 5spd, then to a 2000 Focus with a 2.0L 5spd and now to the Mazda3 with a 2.3L 5spd. What what?! I am moving up in the world!!! baby steps. lol

    That bypass is definitely nice. I have yet to be out there when the "race track"(according to my grandfather) has be finished from Paynesville to Hawick(where my father is buried). But, did go from Paynesville towards Cloud and it's so much nicer now.
     

Share This Page