How to: Install a Forge BPV (MS6 & MS3)

Discussion in 'Facts and How To's' started by Big Nate, Apr 30, 2009.

  1. Big Nate

    Big Nate Chaos Engineer

    I got a new BPV and decided to do a write-up on it.

    Tools needed,
    pliers
    phillips screwdriver
    socket set with a 10mm Or 8mm can't remember.

    Time taken for job,
    About 20 mins



    First thing is, take of the black shroud around the TMIC (top mount intercooler). If you need a picture of this stop right now, put down the torch and take the car to a shop.

    Here is what it will look like when that shroud is off.

    [​IMG]

    This is the stock BPV (bypass valve)

    [​IMG]

    Once you locate this take your pliers and remove the clamps that hold the two tubes that connect to the stocker.

    Small tube (vacuum assist tube, helps to pull the BPV open when you let off the gas)

    [​IMG]

    [​IMG]

    Big tube (recirculation tube, lets the air released from the boost side of the turbo to the ambient side)

    [​IMG]

    [​IMG]

    Now take your socket set and use an extension with your 10mm (or 8mm) socket to get to the two bolts holding the BPV in place.

    Top side bolt

    [​IMG]

    Bottom side bolt

    [​IMG]

    That will allow you to pull the valve out and disconnect the hoses as you go.

    [​IMG]

    Here is what it looks like when you get it out.

    [​IMG]

    This is the new Forge unit I got from MAP .

    [​IMG]

    [​IMG]

    Now just reverse the order that you used to take the stocker off. There is just one difference. Use the supplied hose clamp for the large hose.

    [​IMG]

    Sorry I didn’t get I pic of that part but this is what the clamp looks like

    [​IMG]

    When you’re all done this is what you have.

    [​IMG]

    [​IMG]

    This was one of the easiest installs you can do. It also has great performance benefits if you ask me. The car feels like it pulls much better and has almost no hesitation at all now.



    Feel free to post up your comments and your experience with installing this piece.


    Nate
     
    Last edited: May 18, 2009
  2. JohnnyT

    JohnnyT New Member

    I wish the Synapse one was that easy...
     
  3. WhiteSpy9

    WhiteSpy9 Guest

    Have you checked yours to make sure it was greased and oiled properly Nate?

    I still need to take mine off and check this, but everything is running fine right now.
     
  4. Big Nate

    Big Nate Chaos Engineer

    It sure was greased. Everything was great. not a scratch on the part.
     
  5. mndsm

    mndsm I'M OFFENDED!

    Good writeup Nate. Also, for the Speed 3 guys, this is identical. Except my BOV is chrome and shiny.
     
  6. cosmicspd3

    cosmicspd3 New Member

    Did you get the Forge BPV or BOV?

    I'm about to buy a forge, just waiting for the dealer to fix my squeal noise..
     
  7. Vrickle

    Vrickle New Member

    Thanks for the write-up Nate. If the UPS tracking is correct I will be doing this install this weekend.
     
  8. cosmicspd3

    cosmicspd3 New Member

    Just put mine on, blue spring with 0 shims.
     
  9. VTEC8YA

    VTEC8YA The Story Teller....

    Ive been running blue plus 2 for quite some time. I went with the yellow plus 2 now and it doesnt seem to hold as well and I get quite a bit of flutter it seems. Will go back to blue plus 2 soon.
     

Share This Page